[gelöst] sprut Brenner8 mag PIC10f206 nicht erkennen

Im Unterforum Microcontroller - Beschreibung: Hardware - Software - Ideen - Projekte

Suchen          Elektronik Forum Nicht eingeloggt       Einloggen       Registrieren



Elektronik- und Elektroforum Forum Index   >>   Microcontroller        Microcontroller : Hardware - Software - Ideen - Projekte

Autor
[gelöst] sprut Brenner8 mag PIC10f206 nicht erkennen

    










BID = 752160

Bartholomew

Inventar



Beiträge: 4681
 

  


Hoi,

Habe mir einen sprut Brenner8 Revision 5 auf Lochraster nachgebaut, Firmware 1.15 (aktuell). Über die ICSP-Schnittstelle soll man ja über einen Adapter auch die kleinen 10F20x brennen können. Doch meine 10F206 werden nicht erkannt
Andere PICs (16F84A/628A, 16F886/887, 16F629/675) werden problemlos erkannt, auch über ICSP.

Daher:
Hat schon jemand mit besagtem Brenner besagte µCs erfolgreich brennen können? Stehen ja auf der Kompatibilitätsliste mit drauf. Google schweigt dazu.

Habe den 8-poligen DIP-Sockel mit auf die Lochrasterplatine draufgebaut, Drahtlänge vom ICSP-Sockel 6cm, Clk und Data sind mehrere mm voneinander entfernt, dazwischen liegt +5V, andere Leitungen kreuzen bloß, laufen aber nicht parallel (bis auf eine Masseleitung). Am ICSP-Sockel sitzt ein 100nF, direkt in den 10F20X-Sockel werde ich am Wochenende noch einen einlöten. Außerdem werde ich einen Adapter vom 10F20x-Sockel auf einen ICSP-Sockel bauen; wenn ich damit andere PICs erkennen kann, muss ja mit der Firmware was nicht stimmen, oder?


Gruß, Bartho

[ Diese Nachricht wurde geändert von: Bartholomew am  5 Mär 2011 22:36 ]

BID = 752176

Nukeman

Schriftsteller



Beiträge: 754
Wohnort: bei Kleve

 

  

Hallo Bartho,

dass die 10F20x im DIP-Gehäuse ein anderes Pinning als z.B. 12F629 haben, hast Du
sicher schon bedacht.
Einen 10F206 in SMD habe ich hier mit dem Brenner8 schon erfolgreich gebrannt.
( Der kleine "SMD-Transistor" steuert jetzt ein I2C-Display an und setzt eingehende
V24-Daten um. )

Mit der Leitungsverlegung von Clk und Data ist immer etwas kritisch bei den PICs
und manchmal muss die Vpp auch ein bisschen justiert werden. Was er da gerne
hätte finde ich aber gerade nicht in der Spezifikation.

Gruß
Stefan








BID = 752187

Bartholomew

Inventar



Beiträge: 4681

Hoi Stefan,

Besten Dank für die Antwort. Welche Firmware verwendet Dein Brenner? Zeigt USBurn in den Statusinformationen an, wenn der Brenner erkannt wird.
Die Anschlussbelegung habe ich richtig ausgeführt, jeder Anschluss am ICSP-Sockel kommt auch kurzschlussfrei am IC an, wo er hingehört (dreimal mit dem Multimeter nachgemessen).

Hardwareexperimente gibt's wie gesagt erst am Wochenende, dann auch Fotos.


Gruß, Bartho

BID = 752209

Nukeman

Schriftsteller



Beiträge: 754
Wohnort: bei Kleve

Hallo Bartho,

bin gerade unter Linux unterwegs und müsste neu booten. Das Flashen ist auch
schon ein paar Tage her.
In der Windows-Partition sehe ich aber dass Usburn 110A2 und FlashOver 12.04 liegt. Eins von den beiden Programmen sollte das aber gewesen sein. Wenn's FlashOver
war, muss ich den Chip wohl doch mit dem Brenner5 gebrannt haben.
Sorry, das hilft Dir jetzt sicher nicht besonders viel weiter.

Gruß
Stefan

BID = 752230

Bartholomew

Inventar



Beiträge: 4681

Hoi Stefan,

Dochdoch, das gibt mir Hoffnung, dass doch spruts Software schuld ist und nicht mein Hardwareaufbau
Wobei letzteres wohl einfacher zu richten wäre

Aktuell ist jedenfalls usb111a2.exe. In Firmware 1.13 hat Sprut größere Umbauten vorgenommen, FW 1.15 hatte dann wohl nur einige kleinere Bugfixes. Weiß leider nicht, wann die in Relation zum USBurn rausgekommen sind.


Zitat :
bin gerade unter Linux unterwegs und müsste neu booten.

Kenne ich nur zu gut
usburn für Linux erkennt bei mir noch nicht zuverlässig die PICs, aber bevor ich das richte, müsste ich erst mal PicDev richtig konfigurieren. Momentan nutze ich zum Entwickeln also eh Windoof mit MPLAB.


Gruß, Bartho

BID = 752299

wulf

Schreibmaschine



Beiträge: 2246
Wohnort: Bozen

Hallo Bartho,
hast du Sprut mal direkt angeschrieben?
Er hat mir bereits mal per Email weitergeholfen.
Kann aber etwas dauern bis er antwortet, meistens ist seine Zeit überbucht.

Grüße
Simon

_________________
Simon
IW3BWH

BID = 752404

Bartholomew

Inventar



Beiträge: 4681

Hoi Simon,

Noch nicht, ich kann ja noch keinen vernünftigen "Bugreport" verfassen, da ich ja noch keinen Hardwarefehler meinerseits ausschließen kann


Gruß, Bartho

BID = 752642

Bartholomew

Inventar



Beiträge: 4681

Soo, Adapter 10F20x->ICSP gebaut, ICSP-Schaltung mit 16F628A angeschlossen, wird erkannt.
Anschließend gegrübelt und festgestellt, dass man in USBurn vielleicht doch mal auf 12-Bit-µCs umstellen sollte
Nach einem Neustart von USBurn wurde der 12F206 dann erkannt.
Komisch, kaum macht man's richtig, funktioniert's


Gruß, Bartho


Zurück zur Seite 0 im Unterforum          Vorheriges Thema Nächstes Thema 


Zum Ersatzteileshop


Bezeichnungen von Produkten, Abbildungen und Logos , die in diesem Forum oder im Shop verwendet werden, sind Eigentum des entsprechenden Herstellers oder Besitzers. Diese dienen lediglich zur Identifikation!
Impressum       Datenschutz       Copyright © Baldur Brock Fernsehtechnik und Versand Ersatzteile in Heilbronn Deutschland       

gerechnet auf die letzten 30 Tage haben wir 33 Beiträge im Durchschnitt pro Tag       heute wurden bisher 13 Beiträge verfasst
© x sparkkelsputz        Besucher : 168020584   Heute : 13011    Gestern : 16365    Online : 471        14.8.2022    18:21
11 Besucher in den letzten 60 Sekunden        alle 5.45 Sekunden ein neuer Besucher ---- logout ----viewtopic ---- logout ----
xcvb ycvb
0.0402269363403