Win XP - IDE-Platte bootfähig auf S-ATA-Platte klonen?

Im Unterforum Hardware, Betriebssysteme, Programmiersprachen - Beschreibung: Alles zu Software, Hardware, Windows, Linux, Programmiersprachen
Anfragen zu Modding, Games, Cracks, etc. unerwünscht.

Elektronik Forum Nicht eingeloggt       Einloggen       Registrieren




[Registrieren]      --     [FAQ]      --     [ Einen Link auf Ihrer Homepage zum Forum]      --     [ Themen kostenlos per RSS in ihre Homepage einbauen]      --     [Einloggen]

Suchen


Serverzeit: 18 4 2024  13:04:47      TV   VCR Aufnahme   TFT   CRT-Monitor   Netzteile   LED-FAQ   Osziloskop-Schirmbilder            


Elektronik- und Elektroforum Forum Index   >>   Hardware, Betriebssysteme, Programmiersprachen        Hardware, Betriebssysteme, Programmiersprachen : Alles zu Software, Hardware, Windows, Linux, Programmiersprachen
Anfragen zu Modding, Games, Cracks, etc. unerwünscht.

Gehe zu Seite ( 1 | 2 | 3 | 4 Nächste Seite )      


Autor
Win XP - IDE-Platte bootfähig auf S-ATA-Platte klonen?
Suche nach: ide (651)

    







BID = 895709

Trumbaschl

Inventar



Beiträge: 7558
Wohnort: Wien
 

  


Ich hoffe mal, hier sind auch ein paar Computer-Profis...
Ich hab fatalerweise einem Bekannten angeboten, seinen alten Pentium IV auf Vordermann zu bringen, Gebrauchtnetzteil rein, RAM aufrüsten, Gebraucht-DVD-Laufwerk (Riemen für die Schublade schlapp) und eine neue Platte.

Da kaum noch IDE-Platten aufzutreiben sind, wollte ich mit einer S-ATA-Karte (SIL-Chipsatz) eine entsprechende Platte einbauen.

Dummerweise hatte ich dazu den Auftrag, die komplett vergnaddelte XP-Home-Installation (SP2) 1:1 zu klonen und hier beginnen die Probleme. Der Rechner bootet vom Klon nicht, anscheinend müsste man die boot.ini modifizieren, damit Windows von der S-ATA-Platte starten kann. Kann mir jemand sagen, was ich da genau tun muss? So kann ich entweder von der IDE-Platte booten oder - wenn ich diese ausbaue - kriege ich die Meldung "Ntldr fehlt".

Im allerschlimmsten Fall könnte ich natürlich auch noch auf einer leeren S-ATA-Platte ein XP installieren und dessen boot.ini mit der bisherigen vergleichen, aber das ist mir etwas viel Aufwand.

_________________
"Und dann kommen's zu ana Tür da steht oben "Eintritt verboten!" und da miaßn's eine!"

BID = 895712

Rhodosmaris

Schreibmaschine



Beiträge: 2352
Wohnort: Lindau/Bodensee

 

  

Damit klappts nicht?
http://forum.chip.de/windows-xp-ael......html
Ansonsten fütter mal den Google mit "NTLDR fehlt" - da kommt einiges.

ciao Maris

BID = 895714

Elektro Freak

Inventar



Beiträge: 3405
Wohnort: Mainfranken

Warum keine Neuinstallation ? Für S-ATA brauchts nen anderen Treiber.

Ich würde vom p4 abschied nehmen, für 20 € bekommt man bereits Boards mit Core 2 Duo Prozzesor die um Welten schneller sind.

Vorhin zum Basteln geschossen :

http://www.ebay.de/itm/121152467015.....l2649

_________________

BID = 895716

Her Masters Voice

Inventar


Avatar auf
fremdem Server !
Hochladen oder
per Mail an Admin

Beiträge: 5307
Wohnort: irgendwo südlich von Berlin

wenn das BIOS es zulässt kann man mit dem Kompatibilitätsmodus den Klon anfeharen und dann den modernen SATA Treiber nachinstallieren. Dann muss man beim nächsten Start nur den Modus im BIOS umstellen

BID = 895718

elmo_cgn

Schriftsteller



Beiträge: 588
Wohnort: Köln

Hallo,

im BIOS von der PIV Möhre die SATA Ports auf "IDE Mode" umschalten, dann sollte der Klon booten.
AHCI Treiber nachinstallieren funktioniert bei WIN XP nicht, WIN XP wird zusätzlich ab Anfag 2014 von Microsoft nicht mehr supported, die alte Kiste also am besten entsorgen und einen neuen Rechner mit Win-7 oder 8 besorgen.

Falls die Platte auch im "IDE Modus" nicht bootet, XP CD einlegen und fixmbr probieren.

http://support.microsoft.com/kb/314058/de

Gruß,
Elmar

BID = 895721

Trumbaschl

Inventar



Beiträge: 7558
Wohnort: Wien

Ist nicht mein Rechner, der Auftrag war strikt, die Kiste mit minimalem Aufwand wieder flott zu kriegen und die Festplatte aus Prinzip (könnte ja an Altersschwäche sterben) zu ersetzen.

Das mit dem NTLDR kam nur anfangs, inzwischen tut der Rechner so als wäre keine Festplatte vorhanden. Den S-ATA-Treiber habe ich vor dem Klonen installiert, die Platte wird auch angesprochen solange ich von der IDE-Platte starte.

Wo ich aber etwas auf IDE-Modus umstellen soll ist mir unklar - das Setup der S-ATA-Karte bietet nur RAID-spezifische Einstellmöglichkeiten und das Mainboard-Setup kann die Karte nicht erkennen, da sich die erst später in den Bootvorgang einklinkt.

Klingt als müsste ich auf die Karte verzichten und stattdessen einen S-ATA/IDE-Adapter verwenden. Aber wahrscheinlich nimmt der blaue Claus die Karte nicht mehr zurück, Verpackung ist ja naturgemäß offen.

Heiliger Himmel, geht mir der Krempel auf den Geist!

_________________
"Und dann kommen's zu ana Tür da steht oben "Eintritt verboten!" und da miaßn's eine!"

BID = 895722

Trumbaschl

Inventar



Beiträge: 7558
Wohnort: Wien

Nachtrag: KOnfiguration im Board-Setup ist Bootreihenfolge CD-ROM - A - nix, "Boot Other" ist aktiviert.

Die Geschichte mit dem NTLDR verschwand wenn ich mich richtig erinnere, nachdem ich mit XXClone den Klon bootfähig machen versucht habe. Seither kriege ich die Meldung, ich sollte etwaige Medien aus den Laufwerken entfernen und eine beliebige Taste drücken.

_________________
"Und dann kommen's zu ana Tür da steht oben "Eintritt verboten!" und da miaßn's eine!"

BID = 895748

elmo_cgn

Schriftsteller



Beiträge: 588
Wohnort: Köln

Hallo,

also das Hightech Mainboard hat gar keine eigenen SATA Ports und Du hast eine externe PCI SATA Karte eingebaut ?

Wenn das so ist gibt es nur eine Möglichkeit:

1. IDE Platte an den ersten IDE Kontroller anschliessen.
2. SATA Karte einbauen und Platte anschliessen.
3. Im BIOS der SATA Karte Raid deaktivieren und auf Standard SATA einstellen.
4. Windows von der IDE Platte starten.
5. alle Updates, Servicepacks installieren.
6. Treiber der SATA Karte installieren.
7. SATA Platte sollte jetzt erkannt werden.
8. Raidpatches von hier http://www.admins-blog.de/admins-he.....chten
wie beschrieben installieren.
9. Softraid mit IDE und SATA Disk einrichten.
10. nach erfolgreicher Synchronisation der Platten IDE Platte ausbauen und von der SATA Platte booten.

Gruß,
Elmar

BID = 895755

Trumbaschl

Inventar



Beiträge: 7558
Wohnort: Wien

Ich bin jetzt den Weg mit dem Adapter gegangen, das scheint zu laufen, auch wenn er die gestern geklonte Partition nicht mounten wollte. Jetzt klone ich halt nochmal und bete a) dass das Resultat bootet und b) Conrad die Karte zurücknimmt (immerhin stand auf deren Website die Karte sei bootfähig und erst in der Packung, das hinge vom Mainboard ab).

Abgesehen vom Softraid bin ich übrigens exakt so vorgegangen wie beschrieben. Und ja, das ist eine PCI-Karte mit zwei S-ATA-Ports. Das Board hat nur 2x ATA-133, Floppy und das wars.

_________________
"Und dann kommen's zu ana Tür da steht oben "Eintritt verboten!" und da miaßn's eine!"

BID = 895765

Trumbaschl

Inventar



Beiträge: 7558
Wohnort: Wien

Problem auf unerwartete Art gelöst... der Rechner ist tot.

Ich wollte ihn beim Booten mittels Netztaster abschalten, kam stattdessen immer Neustart. Also Stecker raus. Seither geht die grüne LED (die bei diesem Aufbau anscheinend das Vorhandensein der PowerOn-Spannung vom ATX-NT anzeigt) geht für 1 sek an und wieder aus, das wars.

Da genau das die Fehlerbeschreibung des Besitzers war gehe ich mal davon aus, dass doch keine tauben NT-Elkos sondern Board/CPU die Fehlerursache waren. Tja, Exitus... den 1-GB-DDR-Riegel geb ich jetzt auch originalverpackt zurück.

_________________
"Und dann kommen's zu ana Tür da steht oben "Eintritt verboten!" und da miaßn's eine!"

BID = 895821

Trumbaschl

Inventar



Beiträge: 7558
Wohnort: Wien

Totgesagte leben länger... wenn es brütend heiß ist und man mit einem Rechner hantiert, dessen Frontblende fehlt (wer designt ein Gehäuse, bei dem man die Frontblende abnehmen muss, um die Seitenteile runterzukriegen?!?) sollte man genau überprüfen, ob man zum Einschalten wirklich auf dem Powerknopf oder vielleicht doch auf dem Resetknopf herumdrückt...

Außerdem sollte ich wohl eine Brille besorgen, der ganze Zirkus mit PCI-Karte und Adapter war unnötig - das Board hat zwei S-ATA-Ports...

Morgen klemme ich die neue Platte an die internen S-ATA-Ports und versuche es nochmal mit einer anderen, diesmal persönlich empfohlenen Klonsoftware. Nix Windowsbasiertes sondern eine bootfähige Debian-CD.

_________________
"Und dann kommen's zu ana Tür da steht oben "Eintritt verboten!" und da miaßn's eine!"

BID = 895874

elmo_cgn

Schriftsteller



Beiträge: 588
Wohnort: Köln

Hallo,

..... hoffe Deine Zeit kostet nichts, sonst hättest Du auch einen 200 Euro Komplettpc besorgen können....

Zum Klonen mit Linux brauchst Du keine Software.
Ich würde mir die "Systemrescue CD" besorgen.

Nach dem booten des Rescuelinux mit:

dd if=Quellplatte of=Zielplatte
kannst Du die Platten klonen, musst nur vorher rausfinden welche Plate welche Bezeichnung hat.
Die geht mit dmesg , dort nach hda bzw. sda suchen, die SATA Platte wird wahrscheinlich sda sein, die IDE Platte hda.

Zum klonen dann:

dd if=/dev/hda of=/dev/sda

Nach dem klonen muß wahrscheinlich der Bootsektor angepasst werden, das geht mit der Windows XP CD im Reparaturmodus auf der Kommandozeile ( oder Du richtest das Softraid unter Windows ein, geht ganz ohne Linux und Du hast noch ein Raid. )

Gruß,
Elmar

BID = 895887

stego

Schreibmaschine

Beiträge: 2455

Servus!

Ich habe zum Klonen von HDDs schon öfters sehr gute Erfahrungen mit "Drive Image 5.0" (ältere Version) gemacht. Man muß nur wissen, welche Platte die alte und welche die neue ist (meist haben die ja unterschiedliche Kapazitäten, daher kein Problem).
Dann wird die ganze Platte incl. Bootsektor etc. auf die neue Platte überspielt. Den restlichen freien Speicherplatz kann man während der Einstellungen "freigeben", sodaß auch der ganze neue Speicherplatz der neuen Platte verwendet werden kann.

Das Programm bootet auf DOS-Basis von CD oder Diskette, hat aber sogar einen Maustreiber und eine quasi grafische Benutzeroberfläche dabei.
Ich würde zum Überspielen aber die S-ATA-Platte im BIOS auf nativen Modus (= wird erkannt als IDE-Platte) stellen!
Mit USB-Platten geht das leider nicht mangels USB-Treibern im Programm.

Aja, nochwas: Die neue Platte MUSS unformatiert und unpartitioniert sein, also sozusagen wie geliefert. Das erledigt das "Drive Image" selbständig!

Gruß
stego

_________________

BID = 895894

Trumbaschl

Inventar



Beiträge: 7558
Wohnort: Wien

Ich versuch das jetzt mal mit Clonezilla von CD, eine linuxbasierte Lösung, die angeblich problemlos bootfähige Windows-Clones erzeugen kann.

Allerdings habe ich grade folgendes Problemchen: wenn ich den internen SATA-Port im BIOS aktiviere, bootet XP nicht mehr von der IDE-Platte (Bluescreen). Keine Ahnung, woran das jetzt schon wieder liegt... langsam frag ich mich, ob die XP-Installation zu retten ist.

Und nein, meine Zeit kostet leider nix (Student in den Sommerferien). Mit technikerstundensatz wäre ich schon preislich sonstwo, mit Schwarzmarktsätzen (20-30 Euro) vielleicht noch unter dem Neu-PC.

_________________
"Und dann kommen's zu ana Tür da steht oben "Eintritt verboten!" und da miaßn's eine!"

BID = 895897

elmo_cgn

Schriftsteller



Beiträge: 588
Wohnort: Köln

Hallo,

wenn Du die SATA Ports aktivierst ändert sich die Device Reihenfolge und WIndows findet seine Partition nicht mehr ( sollte auch so im Bluescreen stehen ).
Evtl. kannst Du die Reihenfolge im BIOS ändern, falls nicht mit Linux oder Clonezilla klonen und mit der XP CD den Bootsektor korrigieren.

Achte darauf, das die SATA Ports im IDE oder compatibillity mode laufen, AHCI Treiber kann man nicht nachträglich installieren.

Gruß,
Elmar


      Nächste Seite
Gehe zu Seite ( 1 | 2 | 3 | 4 Nächste Seite )
Zurück zur Seite 0 im Unterforum          Vorheriges Thema Nächstes Thema 


Zum Ersatzteileshop


Bezeichnungen von Produkten, Abbildungen und Logos , die in diesem Forum oder im Shop verwendet werden, sind Eigentum des entsprechenden Herstellers oder Besitzers. Diese dienen lediglich zur Identifikation!
Impressum       Datenschutz       Copyright © Baldur Brock Fernsehtechnik und Versand Ersatzteile in Heilbronn Deutschland       

gerechnet auf die letzten 30 Tage haben wir 24 Beiträge im Durchschnitt pro Tag       heute wurden bisher 4 Beiträge verfasst
© x sparkkelsputz        Besucher : 180918386   Heute : 3283    Gestern : 9237    Online : 565        18.4.2024    13:04
12 Besucher in den letzten 60 Sekunden        alle 5.00 Sekunden ein neuer Besucher ---- logout ----viewtopic ---- logout ----
xcvb ycvb
0.046795129776